Debian sobre SLES 10

La cosa es así: Tengo un servidor de pruebas que estoy usando para jugar con Xen. Este servidor corre el Suse Linux Enterprise Server 10 con Xen y toda la parafernalia, y queria poner alguna máquina virtual para comenzar a hacer las pruebas.

Algo que me gusta, pero a la vez me desagrada, de SLES es la forma de administrar el Xen: Gráfico. Bueno, la cosa es que este administrador de máquinas virtuales solo permite crear sistemas guests con determinados sistemas operativos, que son los “soporta oficialmente”. Entre esos soportados oficialmente no está debian. Y yo queria instalar debian!!

Asique como buen geek me las rebusqué y aqui les traigo el procedimiento para instalar un debian sobre un SLES:

  1. mkdir /var/lib/xen/images/debian
  2. dd if=/dev/zero of=hda count=1 bs=1024M
  3. dd if=/dev/zero of=swap coun=1 bs=256M
  4. mkreiserfs hda
  5. mkswap swap
  6. mkdir /mnt/tmp-root
  7. Instalar el debootstrap, que se puede descargar desde aqui.
  8. debootstrap –arch i386 sarge /mnt/tmp-root ftp://ftp.debian.org/debian
  9. chroot /mnt/tmp-root /bin/bash
  10. Configurar los siguientes archivos: /etc/hosts, /etc/hostname, /etc/fstab, /etc/network/interfaces y /etc/apt/sources.list
  11. aptitude install module-init-tools

Luego de eso, y siempre que todos los archivos de configuración estén debidamente creados, solo nos queda crear un archivo de configuración de Xen bajo /etc/xen/debian. Una vez hecho eso, podemos levantar nuestra máquina virtual “a la antigua” con xm create -c /etc/xen/debian/archivo.cfg

Ojalá a alguien le llegue a servir y si no, al menos me servirá para la otra😛

~ by Boris on December 3, 2007.

One Response to “Debian sobre SLES 10”

  1. Hola. Estoy intentando paravirtualizar un debian etch. Estoy siguiendo tu documento y otros que encontré pero no logro obtener el login.
    En la vm carga el kernel xen (de opensuse) detecta los discos virtuales y los monta, arranca el device-mapper y ahí queda.
    Tenés alguna idea de que pueda faltar?

    PD: te está faltando en el documento que tenés que montar el disco virtual antes de ejecutar debootstrap, además en el punto 3 el parámetro es count y no coun.

    gracias.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: